PopClip not working with Obsidian

Wow! Do you use any window management apps? I’m guessing hold-fn-to-hide-app is a feature of something somewhere…

Thanks for the two videos. What’s strange is that the log isn’t moving at all in either video. That suggests something deeper is going on than the issue with the cursor shape. It’s as if PopClip is disabled or at least isn’t receiving any event stream input from macOS,

Is there anything you can think of that could be causing this? Perhaps there is other software running on the machine that interacts with the mouse pointer or enhances the UI in some way?

Sorry, I don’t have any idea what might be causing this behavior. The problems are app-specific - that is, the latest Obsidian update changed its cursor behavior eliminating the problem. The cursor behavior in Ulysses is different from that of most apps - resulting in the problem. The cursor behavior in Drafts can be “manipulated” causing the problem to appear and then to disappear.

Given those three different behaviors I’d guess that PopClip is not receiving information when an arrow-shaped cursor is being used by the app. And, that most apps shift cursor shapes as soon as a selection is initiated - so they don’t cause PopClip any problems.

I asked a friend who recently gave up on PopClip about the app/cursor relationship. For her, the problem was in Safari and was evident with an arrow-shaped cursor.

1 Like

One last thing for now, could you please execute the Terminal command

defaults read com.pilotmoon.popclip

(or defaults read com.pilotmoon.popclip-setapp for Setapp edition)

and send me the results? Either on here, by PM or to support@pilotmoon.com

I sent the terminal command results to your support site.

I’ve sent email to the support sites for Drafts and Ulysses asking whether the cursor behavior I am seeing for their apps is intended or whether there is something on my machine that is the problem.

I’ve also asked several friends who I know use Ulysses whether they see the same “arrow cursor always used” behavior that I do.

I see the same behaviour in Ulysses, although not in Drafts. I’ve added allowances for arrow cursor in Ulysses and Drafts, which will appear in the next beta of PopClip.

However, this mystery of the events not being received by PopClip (i.e. the log not moving in the videos) is unrelated to the arrow cursor. An arrow cursor will not prevent events from being sent to PopClip. Rather, it is PopClip itself that is choosing not to appear when an arrow cursor is used.

Thus, the issue of why the log was not moving in the videos is the principal stumbling block to further progress here. (Unless it is something as trivial as PopClip being turned off while the videos were being recorded??)

BTW, Arrow (as well as pointing hand) cursor is also now allowed in all known web browsers plus a whiltelist of the following apps


I’m using CleanShot for the videos. I just tried a recording and verified that PopClip remained on when the video was being recorded.

And the logs are still not scrolling in the log window at all, while you use PopClip?

Thanks for the update. Curiously, by playing around with Ulysses I can make the cursor shape change - but not reliably. If I triple-click a line of text, PopClip (generally) appears. If I select text from the “bottom-up” I can (occasionally) change the cursor. As soon as the cursor changes PopClip works.

Just sent a video to your support site where the log does seem to be scrolling.