Adds spaces, but only in Messages

My most frequently used extensions are Capitalize and related. One thing I like is you don’t have to be careful to select complete words (saves time, when you can grab in the middle of a word), the extensions still work properly.

A few months ago, only in Messages app, my selection is bracketed by added spaces, so I have to be careful to select complete words. This even happens if the extension you’re using is Remove Spaces! Try it — it removes the selected spaces, but it adds spaces at the beginning and end of the selection!

I recently updated from the MAS version to the Popclip-licensed one, no dif.

That’s weird! I just did a test in Messages ands I can see what’s happening. Messages itself adds a space before and everything everything you paste.

Try it yourself – with PopClip disabled, paste a word in the middle of another word:

CleanShot 2024-05-24 at 22.04.25

So since Messages itself adds the spaces, I don’t think there’s much PopClip can do :frowning:

1 Like

Now I’m embarrassed that I never noticed that.

Of course the programmers thought they were being helpful. Still, I really dislike nanny software. Automatic numbering in word processors is the worst!

Thank you for taking the time to look. Your responsiveness is #1! Compare that to the other day when I waited seven hours in a queue for a support chat.

1 Like

Yeah, just give me consistency and predictability please! I wonder why they thought that Messages uses can’t type their own spaces yet manage fine with every other app. I guess It’s a carryover from something they added for iOS.

1 Like

I assumed it has to do with Messages being used almost exclusively on phones, where text editing is less convenient.

1 Like