All my extensions have gone after latest PopClip update

Hi Nick

I updated to the latest version of PopClip 2024.3.1 (4513) this morning and now all the extensions I had installed are no longer showing in PopClip.

I have quit and relaunched, but they are still not showing up. Any ideas why they suddenly disappeared?


Hi Craig, let’s get to the bottom of it.

Can you tell me some more details:

Are you now using the Setapp or Standalone of the edition of the app?

Did you migrate from Mac App Store edition, or did you update from the same edition?

Hi Nick

Standalone version and migrated from Mac App Store edition.

Screenshot of ScreenFloat at 25 Mar 2024 at 16_38_22

Did you by any chance use an "app cleaner’ or “uninstaller” tool to delete the MAS version? Or perhaps use an app like Hazel that cleans up after an app is removed? That could have deleted the extensions.

Anyway, lets see if they are still there. Look in the folder ~/Library/Application Support/PopClip/Extensions (PopClip can open that with the Reveal in Finder action, naturally). If they are still on the Mac, you will have a .popclipext in there for each extension you ever installed. Double-click those to install them.

I didn’t use an app cleaner to remove the MAS version, I just removed it from Launchpad.

I checked the location you mentioned and there’s nothing there unfortunately. It’s not a problem for me to re-install the extensions, but just thought it was strange that the extensions worked fine after the initial migration to the standalone app, it was just after the update this morning that they disappeared.

Ah, wow. Now that is a mystery. I’ve never heard of that happening before and I can’t think of a mechanism that would cause it.

Hey Nick

My apologies. I have just checked back and it seems that I did actually run a Smart Scan in CleanMyMac X after installing the standalone version of PopClip. So that may well have had something to do with it.

Interesting … yes, CleanMyMac could indeed have removed the preferences and Application Support folder if the scan was run during the time the app was not present on the system. But if the PopClip was still present I would not expect it to remove anything. Perhaps CleanMyMac got confused by something. Anyway, thanks for updating me on that as the possible cause – it’s very useful for me to understand the cause of issues.

1 Like

Yeah, I thought it was strange too, but still thought I should let you know.

Another thing I have just noticed is that some extensions are now showing as text and not icons. I saw another thread where the OP reinstalled the extensions and that cured the issue. Will give that a try myself.

1 Like

I’ve now re-installed my extensions (and added a few more :wink:) and all is working perfectly now. Thanks for all your help @nick :smile:

1 Like