Cannot Install Extension (name: A name is required)

I’m trying to make my own extension for Brave Search, but I’m getting this error when I try to install the extension:

Screenshot 2024-04-13 at 11.36.55

The folder includes config.yaml (I’ve also tried with a config.json file) and bravesearch.gif.

My config.yaml file content is:

# popclip Brave Search extension
name: Brave Search
identifier: com.pilotmoon.popclip.extension.bravesearch
icon: bravesearch.gif

I’ve tried variations of changing the order of properties, adding and removing some of them, updating to the latest Popclip etc. to no effect.

Where am I going wrong?

I’m using 2024.3.2 (4516) on macOS 14.4.1.

The yaml you posted looks fine, and includes the name, so ought to load OK. Although you will still get an error about using com.pilotmoon. prefix for your own extension.

Could you send me the actual zipped .popclipext package itself so I can take a look?
You can email it to

Just replying for the benefit of other readers, that the problem turned out the the config file ws named config.yaml instead of Config.yaml

(The error message will be made more informative!)