Can't Active Old Version of Popclip

Greetings, I’m in the process of setting up two older macs (one running snow leopard, other mountain lion) and I’m struggling to get pop clip set up. I have purchased the mas version, but when trying to install it (or any other mas application) I get a The server gave an error during download: 503 Service Unavailable error. Even having on tried multiple networks, reinstalling the os on both machines multiple times over the past week and setup two different app store accounts I can’t get past this error.

Having said that I did find that popclip does have an older versions page and an activation license that I could try using (Old Versions), but when I try to actually use the license provided on the site (with both 1.4.9 and 1.5.3) I get a License File not Valid error. Is there some special process here or something I’m missing?

Seems like there might be something wrong with the old versions license key file I have on the site. Can you send me an email, and I can send you a personalized file.

I have a similar problem. I bought a new mac-mini and gave the old one to my spouse to use. I can use Pop-clic fine on the new mac but the older on (mac-mini OS High Sierra) does not want to install. I went to the app store, tried to buy it but when I did that I got a message saying that I already owned it but could reinstall it. I clicked on the reinstall, seemed to work, but when I tried PC it said that I needed to buy it. Did the same thing a second time, went to Purchased items on Apps and tried to install it from there. All that happened was that it said ‘waiting’ … for hours. I am quite willing to buy it again, but how to do that?? I also tried to get rid of PC on the older machine (searched for popclic in file name anywhere and deleted what I found, but no luck. Best I could get was popclic with 10 trials. What to do?

1 Like

Hi @DonS - welcome to the forum. I replied to your email but I’ll post my repsonse here too in case it is helpful to people:

Buying again won’t solve anything as you have already bought it. We just need to figure out what is going wrong.

If it says you need to buy it then you are running the website trial version of the app. Sometimes you can end up with more than one copy of the app on the Mac and it is not clear which one you are launching.

I recommend first of all to thoroughly remove any copies of PopClip from you Mac (check Applications folder, Downloads, Desktop etc.)

Once all removed then try reinstalling from App Store again.

Your advice worked. I had tried that before but I guess I didn’t get all the extra files. This time I was careful to be certain they all were deleted, and then reinstalled PopClic. Works perfectly.
Many thanks. I was gettinq quite frustrated.

1 Like

Looking back through my bookmarks I just realized I never marked this thread as solved, apologies for that.
For anyone new reading this, it was in fact an issue with the license key file for these older versions. After emailing Nick at I was able to get a personalized license key and got both macs up and operation within the next day :grin:.

1 Like