[FIXED] Migration from MAS version not working

EDIT – I found a workaround:

I wasn’t able to redownload the MAS version, so I installed an older MAS version of PopClip from a backup—always make backups, people!—, and then the Mac App Store allowed me to at least update the old MAS version to 2023.x.

Then I just followed the migration tutorial here: Migrate from the Mac App Store (MAS) edition to the Standalone edition — PopClip

  • launch latest MAS version once
  • quit & move MAS app to macOS trash
  • install the dev direct version & launch


Can’t say why (a) I wasn’t able to redownload the MAS version, and (b) why the backup didn’t register… maybe v1.5.8 was too old a version to update the MAS receipt/license in iCloud, so v2024 of PopClip was unable to pick it up.

But the fact that the original redownload from my App Store account didn’t work, might be a bug on Apple’s side.


If I recall correctly, I had already switched from the MAS to one of the earlier direct dev versions, possibly 2022.x or 2023.x. Now, after a year or so (including some time when PopClip hadn’t been in use), when MacUpdater told me that a new version was available, I updated to 2024.3.x, and suddenly PopClip says that the trial has expired, and that I need to buy it.

I tried installing again from the Mac App Store, but the download doesn’t work.

I reinstalled the MAS release of PopClip from another Mac’s old backup (v1.5.8), and this version ran OK. Then I quit that old version, relaunched the new one (2024.3.1), but it still says that the trial has expired.

How should we proceed in this matter, @nick ?

Screenshot 2024-03-24 at 10.51.19

Old MAS version running fine:

Screenshot 2024-03-24 at 11.03.21

Damn it… it finally worked. I’ll post the How-To above in the OP.

Screenshot 2024-03-24 at 11.08.41

Well that wasn’t the smoothest experience for you. What version of macOS are you on, Jay? I’d be interested to understand why it wasn’t possible to reinstall it from MAS.

1.5.8 is indeed a rather old version, 6 and a half years old in fact.

Most people have told me it all went very smoothly for them so hopefully this is a relative outlier.

I’m (still) on Ventura… waiting for the iCloud Drive bugs to be fixed on Sonoma. But I don’t think that Ventura is the reason the direct redownload of the last MAS version didn’t work. Maybe it’s because I had never installed that particular version (2023.9)? I had already switched to PopClip SA years ago, as soon as it was available outside of the MAS, so the last MAS version I had installed was surely an old one, maybe not as old as v1.5.8, but somewhere in that range. So maybe the MAS thought I somehow wasn’t eligible to redownload, because it had never registered my account installing this far newer version. (Maybe because of the different versioning scheme with years instead of version numbers the MAS thought it was a major upgrade and needed me to jump through those hoops? Seems far-fetched, but maybe not for Apple. :wink:)

1 Like

I’m a little confused! If you already switched to Standalone edition years ago, then you already migrated way back then. (The MAS → Standalone license recognition has been working for a very long time.) There would have been no need to do anything new this week in that case. You could have just carried as you were on and done nothing :slight_smile:

The migration instructions are meant for poeple currently using the MAS edition. Anyone already running the Standalone edition (even if they originally bought on MAS) doesn’t need to do anything at all.

But, regardless, looks like it’s all sorted now I think?

Everything’s fine. As a matter of fact, I expected it to work as you just wrote, i.e. that the new standalone update would just continue to work, since I was already using a cross-licensed SA version. But for some reason it didn’t work. Can’t say why, of course, since I don’t know how PopClip SA determines if a valid MAS receipt is present. But see screenshot: the receipt of the last MAS version (#1) seems to use a format different from the older MAS version (#2).

So maybe the older standalone version of PopClip, which I had been using before, works fine with the older MAS license, while the newer standalone version (2024.x) does not. (?)

(Still doesn’t explain why Apple didn’t allow me to download from the MAS.)

Older backed-up MAS version’s receipt would likely fail to validate because of the expiry of an Apple signing certificate, which happened a couple of years ago. Only receipts that had been refreshed from Apple since a certain date will validate. What’s that tool fromAppStore, by the way?

1 Like

It’s a tool by Patrick Wardle from Objective See: GitHub - objective-see/fromAppStore: checks if an application is pristine (untampered) and from the official Mac App Store

In the end it’s just a component he uses in his proper utilities, e.g. the WhatsYourSign Finder extension, so users need to build it themselves.

1 Like