Issues with Reminders Extension Activation on macOS

Dear PopClip Forum members,

I am reaching out for your help regarding a problem I am experiencing with the Reminders extension on the latest version of macOS. I have followed the appropriate installation procedures for this extension. However, upon attempting to activate it, I’m faced with a persistent issue.

Whenever I try to activate the Reminders extension, I am only met with a waiting prompt, with no further actions or messages following this. Essentially, it seems that the Reminders extension is stuck in a loading state, with no sign of successful activation or error messages.

I’ve tried multiple restarts of my system and reinstallation of the extension, but the issue persists. I would greatly appreciate it if anyone could offer some guidance on how to address this issue, or if there are any known troubleshooting steps for this kind of problem.

Looking forward to your responses and thank you in advance for your help!

Best Regards,

Hi Pan, can you confirm the version of PopClip you are using?

Hi Nick,

Thank you for your response. My PopClip version is 2022.12 (4069), and I’m using the latest operating system on my Mac mini Pro.

Best regards,


Can you take a look in your System Settings, Security and Privacy, Automation and see if Reminders is checked under PopClip

(ignore that I have two PopClips in my screenshot :slight_smile: )

Dear Nick,

Thank you for your email.

I have confirmed that the Reminders has been checked under PopClip as you requested. However, to completely solve the issue, I would appreciate if you could assist further in checking the settings or possibly troubleshooting any potential issues.

Your expertise and help are greatly appreciated.

Best Regards,

I’m not sure what other troubleshooting to do at this point. Maybe something will occur to me.

Try creating a new test user acount and see if it’s different.

Nick, I assume PopClip won’t run in safe mode, yes?

I’m not sure – I never tried it!