PopClip launches but no UI appears

Hi all! PopClip seems like a great application, so i wanted to test out the trial before deciding to make the purchase. However, after unzipping the downloaded file, PopClip.app won’t open for me. Well, in fact, it will open (since i do see the process running in the Activity Manager) but nothing happens. The interface of the application just doesn’t launch and i also don’t get any error message in macOS. I tried 2 different versions - the 2022.12 release and the PopClip Build 4129 release. Purchasing via the App Store is not really a solution at this time, since I’d like to try the application out for a bit first. Any idea what might be the problem here and how I can fix it? Thanks for your help!

Kind regards,


1 Like

Not sure, but I’ve heard one or two people say the same thing happened over the years but I seem to remember it was transitory. Dare I suggest a reboot?

Also sometimes there are interactions with menu bar organiser apps like Bartender, Vanilla and such. Could it be that?

Thanks so much for your response! I tried quitting all menu bar organiser (and other) apps and rebooted multiple times. Unfortunately, the problem still persists.

I’m going to have to put my thinking cap on.

Let’s gather some data. Questions:

  1. Do you have a directory ~/Library/Application Support/PopClip?

  2. In particular, does it contain a file called _LaunchData and if so, would you send it to me?

  3. What is the output of running defaults read com.pilotmoon.popclip in Terminal, if any?

  4. And if there is text output, can you send it to me?

Feel free to continue here or move this over to email via support@pilotmoon.com if you prefer.

Thanks, I’ll contact you over email right away and update this post if we find a solution.