Problem with ChatGPT extension

I am not able to use Chat GPT. Can someone please help?

You’ll need to be more specific about the problem you are having. What exactly have you tried already, and where does it seem to be going wrong?

Hi Dear Nick…

I installed the extension and also entered the API Key… but when I tried to run, it did nothing. When I click on any word and then in the Pop-Up, select the ChatGPT icon… it circles for few seconds and then disappears.

Moreover, I tried on other platforms with the API Key, for example on Alfred… it immediately worked.

I still have unused tokens, so credits are not an issue for me.

Which version of the extension exactly are you using? Is it the one downloadable from the extension page on the website or one of the snippets in the forum thread?

From the extension Page.

It looks like we need to investigate the debug output from the extension. Here’s how:

You can enable extension debug output by pasting the following command in Terminal:

defaults write com.pilotmoon.popclip EnableExtensionDebug -bool YES

then Quit and restart PopClip.

(note, substitute com.pilotmoon.popclip-setapp if using Setapp edition)

Then open Console app and set the following filters process: PopClip, category: Extension

Now set Console to “Start” & “Now” you should see the API calls going in, and the responses.

Once you’ve set up the debug console, there should be some clue in the error messages as to the problem.

1 Like

I see… It seems like the output is generated at the backend… but there’s no pop-up to show that output. What to do? I understood that, PopClip might require 'PasteText" kind of thing… is it so?

One more thing, I found that, while using this in Typora, it pasted the output quickly as desired…

I was under the impression that, it should pop-up or in a mini note-window it will show the output. But this requires some pasting environment I guess.

Yes, the output of the extension is pasted in the context of the selected text. You could alternatively hold shift to copy the output to the clipboard. It doesn’t have a way to display in a window or pop up.

Gotcha, thanks for clarification!

So, now there’s no issue.

This is one of the remarkable productivity apps I have ever used. Yesterday just came across and immediately purchased. Even at that time, I was unaware about extensions :smile: So it’s a cake on TOP.

Thanks a ton Developer for this awesome creation!

Can’t think enough, how we can simply do tons of things from selecting a text… Mind-Blowing !!!

Two Requests:

  1. Could you increase the limit of extension to 50 or so?

  2. Please att extension for “Rebrandly” too just like “”.

Enter this in your terminal and restart PopClip.

defaults write com.pilotmoon.popclip MaxNumberOfExtensions -int 50


Great! It worked… only the problem is, I can’t scroll down to see the full list… :sweat_smile:

Now you found out why there is a limit :slight_smile:

Oh…but there are two ways to handle this : 1. Provide Scroller or 2. Provide another tab.

I am asking this for an icon in the Menu bar… wherein I click on PopClip icon to see all the available extensions… this may be a workaround :wink:

For instance, you can have a look at “Folder Peek” app.

You’re saying scroll views and tab views existed all this time and nobody told me!? :wink:

Haha… I leave up to your discretion… honorable developer :smiley:.

1 Like