App Store shows "Open" button but app is not in Applications folder

I am using:

Computer: iMac (Retina 5k, 27-inch)
Processor: 3.3 GHz 6-Core Intel Core i5
OS: Mac OS 13.0.1 (Ventura) oh
Popclip app: Latest version on iMac App Store

I visited this forum recently and found the answer I required in the following post:

After I downloaded Popclip from the App Store, I continued to use Popclip successfully. I recently rebooted my iMac and noticed that Popclip was not running. Now I have a contradiction…

As the enclosed image demonstrates, there is no Popclip application in the Applications folder (nor in my home Applications folder). However, when I access the “App Store”, the application shows as “available” - the “open” button is displayed and not the “install” button.

To add to the confusion, I could not find the application on my backup (Time machine).

I am at a loss as to what has happened - any help would be appreciated.


PS. I have not tried clicking “Open” as I thought it better to seek advice first.

1 Like

If the Open button is appearing, it means App Store can see a copy of somewhere on your local machine. It could be in a different folder than Applications. Frequently, people run it from the ~/Downloads folder, but it could be anywhere.

It is safe to click Open – it’ll just open the copy of PopClip you have installed, wherever it is.

To locate an app, click the  menu, hold ⌥ and click System Information. Then click Applications in the sidebar. Wait a few moments for the list to populate, and it will show all the apps macOS knows about. Click the name of an app to see its location:

As you can see I have several PopClips but most people will just have one :slight_smile:

Once you locate PopClip I recommend moving it to the Applications folder for most reliable operation.

Well, I did search for the app in the whole system. No sign it. But I checked it in System Information anyway - and it was not there.

So, I clicked “Open” in the App Store. And now…

Popclip appears in the status bar, but I still cannot find the app on my system as the enclosed screenshot demonstrates !!

Any ideas?

Thank you for your assistance.

Hmm, what a mystery. So here’s how to find it, while it is running.

Open Activity Monitor app and locate PopClip in the list.
Then click the “i” button in the toolbar.
The information window will appear; click the third tab named “Open Files and Ports” (see example)
In this window, you will see various paths, which should give a clue as to the location of

Mystery solved !

I retain copies (current and old versions) of my software. I mark this folder with a ‘.noindex’ extension as I do not wish search to find multiple copies of the same application.

I had copied Popclip to this folder intending to then copy it onto the main Applications folder. And… well you can guess the rest. Anyway, problem solved.

Thank you for your assistance.

1 Like

Haha! Wow, that’s a new one for me. Glad it is solved.

Actually that .noindex could come in quite handy , I’m plagued by multiple copies (as you saw in last post…)