A PopClip extension for ChatGPT

Since the ChatGPT extension seems to be working well and is getting pretty popular, I’ve created an “official” downloadable version and added it to the main extension directory.

The new version includes a few refinements over the one in this thread. See forum post.

Bizarrely, it doesn’t work for me.

I put an API Key and I’m getting no answer. I tried in Notes, Word…etc…

See here:

Ps: I have a ChatGPT Plus account but not a Paid API account but I understand I don’t need one?

Fairly sure you need to have a paid API account. For me it also only started working once I had configured that.

What do you say @nick ?

@rdouma is correct, and it is the most likely explanation. Have you checked the paid credit status of your OpenAI account @jberrebi? Failing that, there are debug instructions in this post.

I added my credit card to my OpenAI account and it works indeed :slight_smile:

This extension is really a killer app.

Thanks @nick and @rdouma

I need a proxy to access OpenAI. Is it possible to use axios proxy?

The proxy config is not working properly:

const openai = require("axios").create({
    baseURL: "https://api.openai.com/v1",
    headers: { Authorization: `Bearer ${options.apikey}` },
    proxy: {
        protocol: 'http',
        host: 'localhost',
        port: 7890,

I see that some people have found a workaround using HttpsProxyAgent, but this package seems not applicable in Popclip extensions.

It’s a little in-depth for me to dive into right now, but if Axios supports proxy config like that, I would expect it to work. However, the log shows that the underlying XMLHttpRequest is going directly to the API, so it isn’t using the proxy.

Modules loaded within popclip extensions are bundled inside PopClip’s executable. The current bundle axios version is 0.26.1. There are only a small number of other modules bundled, but none for networking.

However, I notice your proxy uses HTTP, and unfortunately, PopClip will refuse to make an outgoing connection that isn’t https anyway, even to localhost. So even if you get the proxy set-up working, it won’t connect :frowning:

A post was split to a new topic: Bing chat extension

I got an access to ChatGPT4 API.

I updated the code and installed the new extension.

I tried to use it but I’m getting axios errors

Error: Request failed with status code 429

Result: error: Error: Request failed with status code 429 (axios.js.lzfse:667:24)

‘paste-result’ was specified but there is no result text

according to OpenAI, they sent back an answer but I never got it…

Any idea?

1 Like

HTTP error code 429 is “too many requests”; perhaps you are encountering some sort of rate limiting?

It looks like OpenAI is an article about it: https://help.openai.com/en/articles/5955604-how-can-i-solve-429-too-many-requests-errors

I got the same error with my very first requestion…Bizarre

Do you have an access to ChatGPT4 API yourself? Is it working?

I don’t have it. Are you accessing it from your company network? It could be other usage from your organisation.

I’m the owner of the company and managing the main account.
Now it works. I don’t know why!
All good!

1 Like

I have followed this and am a paid ChatGPT user, but it doesn’t do anything. A little X pops up and shakes and then nothing. Any suggestions?

You’ll also need to add credit to your API account. It is not included in your ChatGPT subscription. (See posts above.)

Can you give me a code to use gpt-4? I tried to change the above code, but it didn’t help(

I haven’t looked at the GPT-4 modifications because I don’t have API access myself yet. If you do have access, my guess is that you just need to change the constant gpt-3.5-turbo to gpt-4 (based on https://platform.openai.com/docs/guides/chat)